구글 한글 키보드 패키지 서명 문제

by H.F. Kais | 2012. 2. 19. | 5 comments

이 문제는 3월 11일 이루어진 hTC의 어플리케이션 업그레이드를 통해 해결되었습니다. FOTA방식으로 업그레이드하면 문제가 해결됩니다. 관련 공지는 hTC의 페이스북에서 확인하실 수 있습니다.

iOS와 비교해 안드로이드의 강점이라면 다양한 입력기를 선택할 수 있다는 점입니다. 전통적인 쿼티자판 외에도 다양한 방식의 키보드를 선택할 수 있죠. 기존 피쳐폰에서 쓰던 천지인이나 ez한글 같은 입력방식도 그대로 구현되어 사용자 입맛대로 고를 수 있습니다.

다양한 입력기 중에서도 최근 인기 있는 것은 '구글 한글 키보드' 입니다. 단모음 방식을 채택, 오타 없이 빠르게 입력할 수 있어 많은 사랑을 받고 있습니다. 단모음 방식에 익숙해지니 일반 쿼티 방식은 불편하더군요.

 

'구글 한글 키보드' 가 2월 7일자로 업데이트 되었습니다. 버전은 0.78에서 0.82로 올랐습니다. 이번 버전에서는 안드로이드 4.0 아이스크림 샌드위치(ICS) 테마를 적용했다고 합니다. 전체적인 색 분위기도 약간 바뀌고, 키 디자인도 살짝 변경된 듯 합니다. 하지만 전 아직 써보지 못하고 있습니다.

구글 한글 키보드 패키지 서명 오류 업데이트 버튼을 누르면, 다운로드 후 설치 과정에서 '패키지 파일이 올바르게 서명되지 않았습니다. 이전 앱 사본을 제거하고 다시 시도하세요' 란 오류 메시지가 나타나면서 업데이트가 취소됩니다.

저는 디자이어HD를 사용하고 있습니다만, 제 폰만의 문제가 아닌 것 같더군요. 사용자 리뷰란을 보면 저와 같은 문제를 호소하는 분들이 많습니다. 주로 디자이어HD와 EVO4G 사용자들이 같은 문제를 겪고 있는 것 같습니다.

저는 이 문제를 구글 안드로이드 마켓(gpk-usersupport@google.com)에 문의하였고 여러 개의 메일이 오갔습니다만, 아직 문제는 해결되지 않고 있습니다. 안드로이드 마켓 담당자는 마켓 어플 초기화 및 다운로드 매니저 초기화(데이터, 캐시 지우기)를 해결방안으로 제시했습니다. 물론 이 방법들은 소용이 없었습니다. 항간에 구글 한글 키보드 앱을 초기화 하면 되는 경우도 있다고 해서 그대로 해봤지만, 마찬가지였습니다.

이 문제는 현재 hTC 쪽에서도 알고 있습니다. 문제 해결을 위해 노력하고 있다곤 하는데 아직 변변한 진행상황이나 해결방안 등은 나오지 않은 상황입니다. 통신사인 KT에서도 별로 뾰족한 수는 없는 것 같고요.

벌써 2주일 째네요. 언제쯤 업데이트할 수 있을까요?

덧) 구글 한글 키보드 0.82 버전의 APK 파일을 구해서 설치를 시도해 봤지만, 되지 않는군요.(12-02-20)

덧2) 결국 hTC에서 자체 업데이트를 통해 해결했군요. '소프트웨어 업데이트'를 통해 새 버전의 구글 한글 키보드로 업데이트 되었습니다.(12-03-11)

댓글 5개:

  1. 제 기기는 hTC WildFire인데 구글 한글키보드가 지원되지 않는 기기입니다. ㅠ.ㅠ

    Ez 한글입력기를 키보드로 사용하고 있는데, 최근에 구플에서 알게된 반추키보드를 사용하면서 만족하고 있어요. 화면이 작은 WildFire에 적합하면서 이지한글도 지원하니 말입니다. ^^

    답글삭제
    답글
    1. 깔끔하니 예쁘게 생겼네요. 지금은 multiling이랑 구글 한글 키보드를 병행해서 쓰고 있는데, 이것도 한번 써봐야겠습니다. ㅎㅎ

      삭제
  2. 설정>휴대전화정보>소프트웨어 업데이트로들어가서
    지금확인 누르면 응용프로그램 업뎃이 된답니다~

    답글삭제
    답글
    1. 네 결국 마켓에서 해결 못하고 hTC에서 자체 업데이트로 해결했더군요. 올라온 날 바로 업데이트하긴 했지만 반츄키보드의 매력에 빠져 아직 반츄를 쓰고 있습니다 ㅎㅎ

      삭제
  3. 아~~~~ 속 씨~원~~~하네요 ^^*
    하 이것땜에 정말 짜증났는데 ㅋㅋㅋ
    소프트웨어 업데이트 확인하니 바로 뜨네요 흐하하 ㅋ

    답글삭제

- 스팸 방지를 위해 보안문자(캡차) 확인을 사용하고 있습니다.

덧글 페이지로 이동합니다. 스팸방지를 위해 '단어확인'을 사용하고 있습니다.